Sicherheitsupdate für PHP

SicherheitSicherheitsmanagement

PHP 5.2.11 bringt über 75 Bugfixes, darunter auch einige für sicherheitskritische Fehler.

Die PHP-Entwickler dichten mit der Version 5.2.11 der Skriptsprache einen Fehler bei der Validierung von Zertifikaten in php_openssl_apply_verification_policy ab und einen in popen, der zu Abstürzen führen konnte. Zudem repariert man den Gültigkeitscheck für den Farbindex in imagecolortransparent und führt eine solche Überprüfung für EXIF-Daten ein. Dazu kommen zahlreiche Bugfixes für nicht sicherheitskritische Fehler, die im Changelog nachzulesen sind. (Daniel Dubsky)