PHP 5.2.7 zurückgezogen – Version 5.2.8. bessert nach

SicherheitSicherheitsmanagement

Wegen eines Fehlers haben die PHP-Entwickler die gerade erst veröffentlichte Version 5.2.7 zurückgezogen. Eine neue Version, die den Fehler behebt, hat man aber schon nachgeschoben.

Nur kurzzeitig war PHP 5.2.7 verfügbar, dann wurde es zurückgezogen, weil magic_quotes_gpc sich nicht aktivieren ließ – als Status wurde zwar on angezeigt, doch die Funktion blieb deaktiviert. Den Fehler behebt man mit Version 5.2.8, die ansonsten keine weiteren Veränderungen bringt. Wer nicht schon wieder eine neue PHP-Version aufspielen will, kann als Workaround auch filter.default_flags=0 in der php.ini setzen.

Mit Magic Quotes werden Nutzereingaben gefiltert – eigentlich ein Sicherheitsfeature, das allerdings oft Probleme macht und sich umgehen lässt. In PHP 6 sollen Magic Quotes daher verschwinden. (Daniel Dubsky)